Programando & andando

Ao tentar criar um projeto novo com o Flutter no Android Studio, aparece sempre o erro abaixo:

* Error running Gradle:
Exit code 1 from: /home/everton/AndroidStudioProjects/flutter_layout/android/gradlew app:properties:

FAILURE: Build failed with an exception.

* Where:
Build file '/home/everton/AndroidStudioProjects/flutter_layout/android/build.gradle' line: 24

* What went wrong:
A problem occurred evaluating root project 'android'.
> A problem occurred configuring project ':app'.
> No toolchains found in the NDK toolchains folder for ABI with prefix: mips64el-linux-android

Para corrigir:

  • Abrir o arquivo android/build.gradle e trocar gradle:3.0.1 por gradle:3.1.1;

Com isso, o erro vai mudar para algo assim:
> Failed to apply plugin [id 'com.android.application']
> Minimum supported Gradle version is 4.4. Current version is 4.1.

  • Abrir o arquivo android/gradle/wrapper/gradle-wrapper.properties e trocar gradle-4.1-all.zip por gradle-4.6-all.zip

Obs: O Android Studio avisa que a versão mais recente do gradle é a 3.2.1, mas não funciona com ela. Só consegui fazer funcionar com a 3.1.1.

 

Fonte: Uns mil sites e StackOverflow

Isso ajudou?